【模板】Dijkstra求最短路II

给定一个n个点m条边的有向图,图中可能存在重边和自环,所有边权均为非负值。

请你求出1号点到n号点的最短距离,如果无法从1号点走到n号点,则输出-1。

输入格式

第一行包含整数n和m。

接下来m行每行包含三个整数x,y,z,表示存在一条从点x到点y的有向边,边长为z。

输出格式

输出一个整数,表示1号点到n号点的最短距离。

如果路径不存在,则输出-1。

数据范围

1 ≤ n, m ≤ 1.5×10^5,
图中涉及边长均不小于0,且不超过10000。

输入样例:

1
2
3
4
3 3
1 2 2
2 3 1
1 3 4

输出样例

1
3

模板

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

typedef pair<int, int> PII;

const int N = 150010;

int n, m;
int h[N], e[N], ne[N], w[N], idx;
int dist[N];
bool st[N];

void add(int a, int b, int c)
{
e[idx] = b, w[idx] = c, ne[idx] = h[a], h[a] = idx ++;
}

int dijkstra()
{
memset(dist, 0x3f, sizeof dist);
dist[1] = 0;

priority_queue<PII, vector<PII>, greater<PII>> heap; //小顶堆
heap.push({0, 1});

while(heap.size())
{
auto t = heap.top();
heap.pop();

int ver = t.second, distance = t.first;
if(st[ver]) continue;

st[ver] = true;

for(int i = h[ver]; i != -1; i = ne[i])
{
int j = e[i];
if(dist[j] > distance + w[i])
{
dist[j] = distance + w[i];
heap.push({dist[j], j});
}
}
}

if(dist[n] == 0x3f3f3f3f) return -1;
else return dist[n];
}

int main()
{
cin >> n >> m;
memset(h, -1, sizeof h);

while(m --)
{
int a, b, c;
cin >> a >> b >> c;
add(a, b, c);
}

cout << dijkstra() << endl;

return 0;

}

【模板】Dijkstra求最短路II
https://piscesfinalizer.github.io/2021/02/22/【模板】Dijkstra求最短路II/
作者
PiscesFinalizer
发布于
2021年2月22日
许可协议