【模板】模拟队列

实现一个队列,队列初始为空,支持四种操作:

(1) “push x” – 向队尾插入一个数x;

(2) “pop” – 从队头弹出一个数;

(3) “empty” – 判断队列是否为空;

(4) “query” – 查询队头元素。

现在要对队列进行M个操作,其中的每个操作3和操作4都要输出相应的结果。

输入格式

第一行包含整数M,表示操作次数。

接下来M行,每行包含一个操作命令,操作命令为”push x”,”pop”,”empty”,”query”中的一种。

输出格式

对于每个”empty”和”query”操作都要输出一个查询结果,每个结果占一行。

其中,”empty”操作的查询结果为“YES”或“NO”,”query”操作的查询结果为一个整数,表示队头元素的值。

数据范围

1≤M≤100000,
1≤x≤10^9,
所有操作保证合法。

输入样例

1
2
3
4
5
6
7
8
9
10
11
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6

输出样例

1
2
3
4
NO
6
YES
4

模板

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <iostream>

using namespace std;

const int N = 100010;

int m;
int q[N], hh, tt = -1;


int main()
{
cin >> m;

while(m --)
{
string op;
int x;

cin >> op;

if(op == "push")
{
cin >> x;
q[++ tt] = x;
}
else if(op == "pop") hh ++;
else if(op == "empty")
{
if(hh <= tt) cout << "NO" << endl;
else cout << "YES" << endl;
}
else cout << q[hh] << endl;
}

return 0;
}

【模板】模拟队列
https://piscesfinalizer.github.io/2021/02/10/【模板】模拟队列/
作者
PiscesFinalizer
发布于
2021年2月10日
许可协议