【模板】区间和

假定有一个无限长的数轴,数轴上每个坐标上的数都是0。

现在,我们首先进行 n 次操作,每次操作将某一位置x上的数加c。

接下来,进行 m 次询问,每个询问包含两个整数l和r,你需要求出在区间[l, r]之间的所有数的和。

输入格式

第一行包含两个整数n和m。

接下来 n 行,每行包含两个整数x和c。

再接下里 m 行,每行包含两个整数l和r。

输出格式

共m行,每行输出一个询问中所求的区间内数字和。

数据范围

−109≤x≤109,
1≤n,m≤105,
−109≤l≤r≤109,
−10000≤c≤10000

输入样例

1
2
3
4
5
6
7
3 3
1 2
3 6
7 5
1 3
4 6
7 8

输出样例

1
2
3
8
0
5

模板

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

const int N = 3e6 + 10;

typedef pair<int,int> PII;

int n, m;
int a[N], s[N];

vector<int> alls;
vector<PII> add, query;

vector<int>::iterator unique(vector<int> &a)
{
int j = 0;
for(int i = 0; i < a.size(); i ++ )
if(!i || a[i] != a[i-1])
a[j++] = a[i];

return a.begin() + j;
}

int find(int x)
{
int l = 0, r = alls.size() - 1;

while(l < r)
{
int mid = l + r >> 1;
if(alls[mid] >= x) r = mid;
else l = mid + 1;
}

return r + 1;
}

int main()
{
cin >> n >> m;

while(n --)
{
int x, c;
cin >> x >> c;
add.push_back({x,c});

alls.push_back(x);
}

while(m --)
{
int l, r;
cin >> l >> r;
query.push_back({l, r});

alls.push_back(l);
alls.push_back(r);
}

sort(alls.begin(), alls.end());
alls.erase(unique(alls), alls.end());

for(auto item : add)
{
int x = find(item.first);
a[x] += item.second;
}

for(int i = 1; i <= alls.size(); i ++ ) s[i] += s[i - 1] + a[i];

for(auto item : query)
{
int l = find(item.first), r = find(item.second);

cout << s[r] - s[l - 1] << endl;
}

return 0;
}

【模板】区间和
https://piscesfinalizer.github.io/2021/02/08/【模板】区间和/
作者
PiscesFinalizer
发布于
2021年2月8日
许可协议